Community and Support

            Why nmap not works / IPAM Subnet scan not completed


            ​​Scenario 1:  (Windows)


             While installation third party files where not installed due to permissions since we are trying to install in silent mode.

            Resolution:  https://deskportal.zoho.com/portal/manageengine/kb/articles/windows-machine-ipam-showing-incorrect-ip-status-or-not-showing-partially-showing-the-ipaddresses-in-subnets
            ​​​​​​
            ​Scenario 2: (Linux)

             If nmap not works in linux machine, We have to change mode to executable.

            Resolution: Go to Nmap directory via terminal. Exceute the command chmod 777 nmap/chmod +x nmap​

            Scenario 3: (Linux)

             Even it is not working after following the scenario 2

            Resolution:

             Download nmap(6.40 linux deb file) from nmap.org. Install it in /usr/bin/

             Go to Opmanager/Nmap directory via terminal. Use mv command rename the nmap to nmap-old
             
             Go to Opmanager/bin directory via terminal. create a symbolic link to installed nmap using the below command

                  sudo ln -s /usr/bin/nmap ../Nmap/nmap

             Now connect to client and scan the subnets.


            Scenario 4: (Windows)

            If customer machine already had customized nmap from other monitoring products. In that case, nmap will hangs in services.msc .

            Resolution:

            Cross check with this solution first: https://deskportal.zoho.com/portal/manageengine/kb/articles/windows-machine-ipam-showing-incorrect-ip-status-or-not-showing-partially-showing-the-ipaddresses-in-subnets

            Copy the Nmap path (Path for ex:- F:\Installation\OpManager\Nmap;) and set in environment variables, Restart the machine to kill all existing process in task manager.​


            ​Scenario 5: (Windows)

            Older version of third party packages(From other network products/Snipper tools) was installed. For ex:- winpcap(Windows packet capture).

            Resolution: https://deskportal.zoho.com/portal/manageengine/kb/articles/windows-machine-ipam-showing-incorrect-ip-status-or-not-showing-partially-showing-the-ipaddresses-in-subnets
            ​​
            ​ PS: After the above even in some customer setup, nmap will not works. In that case we have to install nmap in customer machine and restart will resolve the issue. This was very very rare case.
            Updated: 21 Nov 2016 01:59 AM
            Helpful?  
            Help us to make this article better
            0 0